The lightest PHP database framework to accelerate development

Version: 1.0.1 [22.5KB]
download
Love Medoo?

Why Medoo

Get Started

Composer require

$ composer require catfan/Medoo

Update

$ composer update

Get Started

// If you installed via composer, just use this code to requrie autoloader on the top of your projects.
require 'vendor/autoload.php';

// Or if you just download the medoo.php into directory, and require it with the correct path.
require_once 'medoo.php';

// Initialize
$database = new medoo([
    'database_type' => 'mysql',
    'database_name' => 'name',
    'server' => 'localhost',
    'username' => 'your_username',
    'password' => 'your_password',
    'charset' => 'utf8'
]);

// Enjoy
$database->insert('account', [
    'user_name' => 'foo',
    'email' => 'foo@bar.com',
    'age' => 25,
    'lang' => ['en', 'fr', 'jp', 'cn']
]);
* On PHP 5.4+, you can use [] as short array syntax.